OSとかネットワークとか要は基盤」カテゴリーアーカイブ

SRPMでソースを変更して再度RPMを作成

推奨の方法かどうかわからないので念のため。下はpostfixの例。

yum install yum-utils
yum install gcc make gettext rpm-build

yumdownloader –source postfix
rpm -ivh postfixパッケージ
/root/rpmbuild/SOURCES – ソース
/root/rpmbuild/SPECS – specファイル

ソースのディレクトリに入り、tar.gzを解凍してソースを変更する。
ソースを変更したら、再tar.gzに圧縮する。

rpmbuild -bb –clean /root/rpmbuild/SPECS/postfix.spec でコンパイル。
rpmbuild/RPMS/ディレクトリにrpmが出来上がる。

多分本当はrootアカウントで作業してはいけないと思われる。

Ciscoルータ PPPOE設定例

CiscoのルータをブロードバンドルータのようにPPPOEで使用する設定例。

“”でくくってある場所は適宜設定を行うこと。ちなみにC891FJ-K9での例。フィルタとかは一切設定してないので、適宜設定が必要。

!
! Last configuration change at 05:44:34 UTC Thu May 3 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname “hostname”
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
license udi pid C891FJ-K9 sn “XXXXXXXXXX”
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface Vlan1
ip address 192.168.12.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
interface Async3
no ip address
encapsulation slip
!
interface Dialer1
ip address negotiated
ip mtu 1454
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname “username”
ppp chap password “password”
ppp pap sent-username “username” password 7 “Password”
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.12.0 0.0.0.255
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
line con 0
no modem enable
line aux 0
line 3
modem InOut
speed 115200
flowcontrol hardware
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
!
!
end

 

VSCAサーバをEVCクラスタに乗せる

vcenterを稼働しているサーバが新しく、EVCのモードよりも新しいCPUで稼働している場合。NFSなどの共有ストレージがあることが前提。

1.Vcenterサーバのイメージを共有ストレージ上に乗せる。

2.Vcenterを含まないホストのみでEVCを有効にしたクラスタを作成する。

3.Vcenterを停止する。

4.Vcenterを稼働しているESXiでVcenterのサーバをインベントリから除去する。

5.EVC有効クラスタに含まれているESXiホストで、Vcenterをインベントリ登録し、起動する。

6.Vcenterで前にVcenterを稼働していたホストをEVCクラスタに登録する。

参考URL:https://kb.vmware.com/s/article/2079829